[Updated] When Installing Forum Software Nukes Eveything!

InvisionCommunity - small.jpg

Please scroll to the bottom for the update.

You wouldn't expect the simple process of installing forum software to royally screw up, destroying a database, taking out an already installed forum and not even creating its own tables, would you? Well, incredibly, that's just what happened when I installed the premium Invision Community forum software! Thankfully, this happened on my test system running on my home PC and not the production server, so it's merely an inconvenience to try again and figure out what happened, which I will do when I get some time. Here are the gory details.


NerdZone runs on XenForo not Invision Community

I actually already had the Invision license before I set up this forum, but renewals are very expensive, so I wanted to compare with the other main contenders in the market, namely vBulletin and its spinoff XenForo, which is highly rated. In the end, it was a bit of a tough choice between all three, but I decided to get a new XenForo license and hence we have the forum you see today.

However, IC is still really premium software and has features that XenForo doesn't, so after a while, I wanted to get the latest version to try out, installing it etc, not just try out the online demo, so I renewed it. In fact, after discussing the renewal with one of the cofounders, on another forum, he was kind enough to put a $50 credit on my account to make this one renewal only $100 which was a lovely surprise.


The Installation

I downloaded the installation files and read the installation instructions, including the bit about the license key and test installs. Nothing terribly complicated there.

My home PC is running Windows 10 21H2 and all the latest patches, Internet Information Services 10 (IIS), PHP 8.1.3 and MySQL 8.0.27 which meet the IC requirements. It also had installed on it a development version of XenForo which I hack about with when trying out new things before wrecking the live site (the thing you're reading this on) with them. I expected IC to install alongside XF, creating its own tables and therefore not interfere with it. Err, no. Hell no.

I created a new website on IIS and ran the IC installer. After fixing one minor warning, everything looked great, I filled in the fields for username, database etc and hit Go. It spent a few minutes installing and then offered me the option of displaying the forum, or the admin control panel. I opted for the forum when this horror then greated me!


Invision MIA.PNG


Same thing if I selected the ACP. If I just browsed localhost then I sort of saw a real messed up view of the field names making up the forum structure, but nothing one could actually call a proper web page. Clicking on the links just resulted in the previous screenshot. There was nothing there.

CorruptedView.PNG


Suspecting the worst, I tried to run XF dev and saw this:

XF dead.PNG

Worst confirmed. Yes, my beloved XenForo had been sacrificed at the altar of the evil Invision!

I then checked the MySQL database and saw this:

MySQL tables gone.PNG

A virgin database with the Sakila demo showing, as if I'd just installed MySQL fresh. Where are the tables for XF and IC?!!! Somehow, the IC installer had nuked everything, which is the source of the problem. No wonder nothing works anymore.

The irony of one of the most sophisticated forum software suites around royally screwing up like a demented zombie isn't lost on me which has given me a bit of a chuckle. How embarrassing for Invision lol.

And no, I don't have a backup of this test environment as it's just a scratchpad with nothing important on it, so I'll just start over.

This is going to take some time to investigate, test and fix, which I'll do another day when I have more time. The IC documentation favours the Apache web server, so perhaps this is a clue as to where the problem lies, although it does run on IIS too.

I'll write an updated post once I've done the troubleshooting and have the answer. If anyone has any troubleshooting tips about this in the meantime, then please let us know in the comments. Anything to make this troubleshooting job easier is welcome.


UPDATE 09.04.2022

Ok, so I've finally got back to this.

I've discovered that the original XF installation was still there on the local MySQL database, but for some reasom Workbench just shows a blank database. This is something that I'm yet to get to the bottom of.

Setting the installer up to do an "upgrade" just resulted in a messed up installation that wouldn't run, so the tables were clearly corrupted. Installing it fresh so that it blanked out the tables, resetting the forum to factory default fixed it. I now have a working local XF installation again - hooray, progress!

I then installed Invision again and got the same corrupted result, but this time it didn't touch XF, which still runs fine.

I discovered that installing to localhost/install1 is what caused the problem. Installing to just localhost works just fine and IC runs.

Interestingly, the installer noticed that there's a previous install there in the database. However, unlike XF, it doesn't just warn that it will nuke those tables and start over. Instead it forces one to use a different prefix and there's no way to delete the old tables. Ok, different behaviour, not a dealbreaker. One can always delete the old tables by accessing the database directly. Neither XF nor IC are perfect in this regard.

The official instructions don't say anything about using local folders, just localhost, so it looks like local folders are not actually supported for localhost installs, despite the installer having the option to specify a folder. I did add -TESTINSTALL on the end of the product key, too. Although I don't like it, I can live with this limitation, but it should be explained better in the official documentation and also the option removed from the installer when doing a local install.





Regardless, I've just realised that there's a dealbreaking omission in IC which means that my potential migration from XenForo for the advanced features of IC that I was considering will now not happen: no post numbers.

This is an incredibly basic function that I use all the time on forums for tracking back and forth in long threads and all other forum software has them, free and paid, so I can't understand the rationale for removing them and not even giving the forum owner the option of adding them back.

Forcing a pointless and very inconvenient removal like this on customers of such expensive software (currently $850 for all the modules and $150 renewal every six months) is about as bad as it gets in my opinion and completely unacceptable. What other annoyances on a similar level are in the product I wonder?

When I used IP.B years ago (different branding back then) on someone else's site, v3.x had version numbers just like any other forum software. However, on Googling the issue, I see that they were removed at least a decade ago and there's no way to get them back, other than perhaps some third party add-on, if I can even find one, which isn't acceptable to me. Therefore, I must reluctantly say goodbye to IC. What a shame as it has many good qualities about it.

Think, because of this idiotic, intentional omission, I wouldn't be able to run my 1000 post competition thread as no one could tell when the 1000th post had been reached, not even the head admin!

Finally, I've often said to people that one of the things I like about XF is that it doesn't do anything stupid. Installation issues and missing features like this are what I mean by that. The thing just works and if something breaks, it's not usually XF's fault. This is really important for a hassle-free experience and peace of mind. Well done XF, you remain my forum product of choice. I can see why forum owners are flocking to it.
 
Last edited:

Geffers

Active member
Joined
1 Jul 2021
Messages
32 (0.06/day)
How frustrating, lucky it was a test machine.

We take a lot for granted with computers as generally they just work but behind the scenes thousands, probably millions of instructions are taking place.

Understand wanting to know what happened.

I recently ventured in to crypto currency, a £10 credit to an account appeared but disappeared after app somehow got deleted. I had a passphrase to recover account but £10 gone.

The £10 is not the issue but could have been 100, thousand or more, that is the issue.

May be a mystery you'll never solve.

Geoff
 

Retro

Founder
Staff member
Joined
4 Jun 2021
Messages
2,047 (3.76/day)
I wonder if the "accidentally deleted" app and the loss of the money are actually connected, ie a hack somehow to steal your money.

Whenever I ready about crypto, it always has the whiff of the dodgy about it which is why I've never gone for it, so this doesn't totally surprise me. Perhaps have another play, this time putting in just £5 and see how it goes. If it disappears again, then something dodgy is definitely going on and it's time to walk away.

Was it a smartphone app, or on your PC? If it's an Android smartphone then that could be your answer, since it's not that secure and is why I eventually moved to the iPhone. No Apple fanboy stuff here, I just wanted to be as safe as reasonably possible.
 

Geffers

Active member
Joined
1 Jul 2021
Messages
32 (0.06/day)
It was android. I don't suspect and have no suspicion of any skullduggery but who knows. I shall try another amount.

Geoff
 
Top Bottom